Author Topic: Marantz pm50 amplifier help needed  (Read 495 times)

Offline gnilrac

Marantz pm50 amplifier help needed
« on: November 08, 2018, 05:01:12 PM »
Hi ,I recently acquired a marantz PM 50
Amp sounds good ,but has a issue.
When I turn the volume past the number 14,it loses bass and treble on the right channel by half.
If I turn the volume back to under 14, the sound returns to normal.
It only happens on the right channel.
Any ideas please,thanks.

Offline fdlsys

  • Vinylist
  • Trader
  • Trade Count: (+87)
  • *****
  • Posts: 8,149
  • Total likes: 75
  • Do you like life, sweetheart?
Re: Marantz pm50 amplifier help needed
« Reply #1 on: November 08, 2018, 08:49:40 PM »
Any ideas please,thanks.
Service by an electronics techie is in order.
The four building blocks of the universe are fire, water, gravel and vinyl. Dave Barry
Come back when you’ve lived a little. Miles Davis

Offline marantz123

  • Trade Count: (+1)
  • AVForums Veteran
  • ***
  • Posts: 296
  • Total likes: 8
  • I learnt more from The Internet when it was slower
Re: Marantz pm50 amplifier help needed
« Reply #2 on: November 09, 2018, 01:12:12 PM »
Clean out all the switches and pots(where possible). Theres switchable tone defeat features on some of these amps, maybe a switch is playing up....you'd be lucky..hope its something simple. Good luck :thumbs:

Offline gnilrac

Re: Marantz pm50 amplifier help needed
« Reply #3 on: November 10, 2018, 12:43:10 PM »
Hi cleaned everything with a spray of electric contact cleaner and compressed air,
Still no luck?

Offline Hi-Phibian

  • Commercial Member
  • Trade Count: (+44)
  • *****
  • Posts: 11,956
  • Total likes: 58
  • I really prefer email, see my banner for address..
    • Croak Audio Exploration
Re: Marantz pm50 amplifier help needed
« Reply #4 on: November 10, 2018, 06:46:54 PM »
Technician. 
Proprietor of Croak Audio Exploration.
Fair, not crazy, cash paid for turntables and tonearms from Rega, Linn and Thorens.          http://www.croak.co.za

Offline mygoggie

Re: Marantz pm50 amplifier help needed
« Reply #5 on: November 14, 2018, 02:00:02 PM »
Sounds like a capacitor or two on that channel that has reached the end of its life and is failing with higher power requirements.
Herman

~ To heal the soul is to embark on a new journey. ~

Offline marantz123

  • Trade Count: (+1)
  • AVForums Veteran
  • ***
  • Posts: 296
  • Total likes: 8
  • I learnt more from The Internet when it was slower
Re: Marantz pm50 amplifier help needed
« Reply #6 on: November 15, 2018, 09:24:39 PM »
Hi

Researched a bit about the PM50 today. Theres plenty info and videos on the web about repairing these. Apparently most of the problems are caused by an over-heating STK IC that is used in the preamp stage. The other problem is an overheating resistor (R804) and dry joints on the STK and elsewhere. The replacement STK recommended ( on the web ) is an upgrade on the existing one, as it has better ratings. If you are technically inclined, and are experienced at wielding a soldering iron (otherwise get it to a tech) I guess a good place to start would be checking for dry joints and checking the temperature of the STK....if its too hot to touch...then....its too hot!  Its also on a flimsy looking heatsink, may be a good idea to bolt on extra cooling onto existing heatsink it if possible. 

You mentioned problem from volume setting at "14" ...thats 3/4 way up on the dial...so running quite a bit of steam there....would guess that theres enough heat to cause something to play up.

  Relatively easy to work on as there is a removable service panel underneath that quickly gets you access to the solder side of the board. A good magnifying glass or loupe helps with inspecting the solder joints.

Good luck, at least the amp is working, makes it easier to fault. Get yourself a schematic/cct diagram of the amp  from the web.

Marantz123.