Author Topic: Monster HDMI Cables problem  (Read 651 times)

Offline StewartAylett

  • Trade Count: (0)
  • AVForums Member
  • **
  • Posts: 76
Monster HDMI Cables problem
« on: February 03, 2017, 10:39:03 AM »
Need some Help
I bought Monster UltraHD Black Platinum 4K HDMI Cables for My System
https://www.monsterproducts.com/UltraHD_Black_Platinum_HDMI_with_Ethernet
I'm Having a Problem that maybe someone Can Help me With
I Have one going from My Denon 3200x to my Tv (Works no problems with all sources)
When I attach another of the same Cable to either my oppo 203 or Nvidia Shield they only work when playing video the menu screens don't show up and my tv says no Input ?? press play and the video shows up
When I tried the oppo this morning with the Cable Direct to the tv It worked fine menus came up
When I changed the Cable to the one that came with the oppo it worked via the Denon fine and I have a Cheap 4k cable from ellies thats working with the nvidia Shield via the denon
Tried flipping the cable direction too ???
the Same Cable Worked 100% with my Roku 4
Anyone else Had any of the same experience

Offline chrisc

  • Trade Count: (+81)
  • AVForums Veteran
  • *****
  • Posts: 7,720
  • “Without music, life would be a mistake.”
Re: Monster HDMI Cables problem
« Reply #1 on: February 03, 2017, 12:11:00 PM »
The cable can be damaged.  The connection between the cable and the plug pins is very fine and twisting and bending can dislodge it.  There are 19 wires in there, some thick, most thin.  Exchange it

Offline StewartAylett

  • Trade Count: (0)
  • AVForums Member
  • **
  • Posts: 76
Re: Monster HDMI Cables problem
« Reply #2 on: February 03, 2017, 12:14:57 PM »
The cable can be damaged.  The connection between the cable and the plug pins is very fine and twisting and bending can dislodge it.  There are 19 wires in there, some thick, most thin.  Exchange it

It's 2 different Cables
they were working fine with the roku 4 and Lg Blu ray Player that I've just swapped over
How can I Unplug 1 machine that works 100% replace with a Better machine and It doesn't work ??

Offline StewartAylett

  • Trade Count: (0)
  • AVForums Member
  • **
  • Posts: 76
Re: Monster HDMI Cables problem
« Reply #3 on: February 21, 2017, 09:12:16 AM »
So I swapped the Cable Around I.e the plug that was in the tv went to the source and vise versa and seems to have worked ???
Cable doesn't say it one directional very strange

Offline reactor_sa

  • Trade Count: (+6)
  • AVForums Veteran
  • *****
  • Posts: 1,267
Re: Monster HDMI Cables problem
« Reply #4 on: February 21, 2017, 12:15:31 PM »
"Monster" cable.  What more is there to say. :sh1tstirrer: